Dscp là gì

     

Thông thường, khối hệ thống mạng hoạt động bên trên cửa hàng phân phối hận tốt nhất có thể, Có nghĩa là toàn bộ gói tin vào mạng đều phải sở hữu mức độ ưu tiên ngang nhau với tất cả cơ hội được đưa đến đích một biện pháp kịp lúc. Khi ùn tắc xẩy ra, tất cả những gói tin phần đa có tác dụng bị ùn tắc. Nếu không có QoS, Switch sẽ cung ứng hình thức cực tốt cho toàn bộ các gói, bất kỳ văn bản gói xuất xắc kích thước. Nó đang gửi các gói tin nhưng không tồn tại bất kỳ sự đảm bảo về độ tin cẩn, giới hạn độ trễ hoặc thông lượng làm sao.quý khách đang xem: Dscp là gì

khi ta áp dụng kỹ năng QoS, ta có thể chọn 1 dạng gói tin cụ thể, ưu tiên nó theo khoảng quan trọng đặc biệt tương đối của chính nó cùng sử dụng chuyên môn thống trị ùn tắc và tránh tắc nghẽn nhằm hỗ trợ ưu tiên. Việc thực thi QoS trong mạng tạo nên hiệu năng mạng dễ dự đoán thù hơn với sử dụng băng thông công dụng rộng.

Bạn đang xem: Dscp là gì

II. Cơ chế hoạt động

-Việc triển khai QoS được dựa trên con kiến ​​trúc hình thức dịch vụ phân minh (Diff-Serv), phong cách xây dựng này hướng dẫn và chỉ định rằng mỗi gói tin được phân loại Khi nhập vào mạng. Các gói tin sẽ tiến hành lưu lại nhỏng Class of Service (CoS), DSCP., IP Precedence… Nên khắc ghi gói tin càng cấp tốc càng tốt, Khi được ưu tiên nhanh chóng thì luồng trải qua trang bị tiếp theo sau đang trót lọt tru.

1, Giá trị IPhường Precedence và DSCPhường (Differentiated Service Code Point)

Layer 3

IPhường Precedence với DSCP là hai trường được áp dụng các tuyệt nhất nhằm lưu lại. Các nguyên lý QoS áp dụng bọn chúng chính vì header của gói tin IPhường. trường thọ làm việc đầy đủ nơi trên mạng.Trong IP.. header của mỗi gói tin có cất một trường hotline là ToS (Type of Service). Trường Type of Service có giá trị 1 byte. Và 3 bits thứ nhất (P2 đến P0) dùng để cơ chế các quý hiếm lưu lại độ ưu tiên của packet và những quý giá này được hotline là IPhường Precedence.


*

IP Precedence hoặc DSCP


*

Cấu trúc trường Type of Service

Giá trị IPhường precedence ở trong vòng tự 0 mang lại 7.

Tại sao lại có những khoảng quý giá bên trên, ví dụ như sau:

3 bits đầu tiên (P2 cho P0): IP.. Precedence. Do sử dụng 3 bits yêu cầu sẽ có 8 giá trị (000 mang đến 111) định ra độ ưu tiên của gói tin từ thấp cho cao. Giúp router xử trí các gói tin này theo unique các dịch vụ. lấy một ví dụ, gói tin được khắc ghi với cái giá trị IP Precedence là 7 (111) sẽ sở hữu độ ưu tiên về bandwidth, được thoát ra khỏi hàng ngóng trước… hơn so với các gói tin được lưu lại với cái giá trị IPhường Precedence là 3 (011).

3 bits tiếp theo (T2 mang đến T0):

bit T2 (T2=1): Yêu cầu truyền cấp. bit T1 (T1=1): Yêu cầu truyền với đường truyền rất tốt. bit T0 (T0=1): Yêu cầu truyền bảo đảm.

2 bit cuối (CU1-CU2): Không cần sử dụng cho tới (Currently & Unused).

Tuy nhiên, bây chừ không sử dụng những quý giá của IP Precedence để khắc ghi gói tin. Với mục đích có tác dụng tăng công dụng chất lượng hình thức dịch vụ thì những phép tắc QoS đã sử dụng các giá trị được gọi là điểm mã hình thức dịch vụ rõ ràng DSCP. (Differentiated Service Code Point) nhằm triển khai khắc ghi gói tin. 3 bits IPhường Precedence đang kết phù hợp với 3 bits tiếp theo (trường đoản cú T2 đến T0) tạo nên thành 6 bits diễn đạt các quý giá của DSCP.. Do kia những giá trị DSCP ở trong khoảng từ 0 cho 63.

Các bits này được ánh xạ nhỏng sau:


*

Giá trị IP Precedence có thể được ánh xạ đến trường DSCP

6 bits DiffServ (DS) từ bỏ DS5 mang lại DS0 được dùng làm khắc ghi gói tin cùng chỉ ra cách thức mỗi router cách xử trí gói tin ra làm sao. Với 6 bits có thể tạo thành mang lại 64 class hình thức.


*

IPhường. Header trước và sau lưu lại DSCP

Lựa lựa chọn quý giá DSCP bắt buộc tương hợp cùng với máy trường đoản cú IPhường Precedence. Nói giải pháp khác là đề xuất so trùng khớp giá trị của 3 bits trước tiên. Mọi sự thay đổi các bắt buộc để ý đến sự trùng khớp này.Ví dụ: quý giá IPhường Precedence là 5 (101) thì giá trị DSCPhường hoàn toàn có thể là 101 000.


*

Có những hình dạng chuyển tiếp gói tin trong DSCPhường. là AF (assured forwarding: bảo vệ đẩy gói) và EF (expedited forwarding: xúc tiến đẩy gói), chọn lớp (Class Selector) và mang định (Default).


Ánh xạ thân PHB cùng DSCP

Với EF: độ trễ, độ dịch chuyển trễ, tỉ lệ mất gói tốt, đường dẫn được đảm bảo, với hình thức sau cùng đề xuất trải qua miền DiffServ. EF được thực hiện cho mọi luồng bao gồm độ ưu tiên không hề nhỏ.

Với AF: định rõ số đông dịch vụ khác nhau sẽ tiến hành bảo đảm an toàn nối tiếp, trải qua miền DiffServ. AF được chia làm 4 lớp (class) đảm bảo đẩy gói khác nhau với 3 mức độ ưu tiên loại bỏ gói (drop precedence) xác minh không giống nhau. AFxy, x (chỉ số lớp) càng tốt thì xếp vào sản phẩm hóng xuất sắc rộng, x càng nhỏ tuổi thì sẽ càng dễ dàng bị loại bỏ quăng quật, y càng tốt thì gói tin càng dễ bị loại vứt. Vậy AF41 là gói tin được ưu tiên tốt nhất có thể, mang lại AF42, AF43,… AF13 dễ dàng bị loại bỏ nhất


2, Gía trị cos (class of service) Layer 2

Cos: Class of service: Các lớp các dịch vụ (0 mang lại 7)

Trường CoS chỉ tồn tại bên phía trong Etheframe Khi các đường trunk 802.1Q và ISL được sử dụng. cũng có thể áp dụng trường này để tùy chỉnh 8 giá trị nhị phân không giống nhau cơ mà có thể sử dụng mang lại tác dụng phân một số loại của pháp luật QoS nlỗi IPhường. Precedence cùng DSCP. Giá trị Cos càng cao thì gói tin frame càng được ưu tiên.


Cos 7: Không áp dụng (reserved)

Cos 6: Không thực hiện (reserved)

Cos 5: Dữ liệu voice (voice bearer)

Cos 4: Dữ liệu Clip conferencing

Cos 3: Gọi signalling

Cos 2: High priority data

Cos 1: Medium priority data

Cos 0: best effort data


Hình 2: ví dụ như ví dụ về gán quý giá CoS với DSCP

Theo hình 2, minc hoạ một LAN switch triển khai tác dụng QoS dựa trên CoS. R3 phát âm các frame đi vào bên trên một cổng (ví dụ F0/9), ghi lại cực hiếm DSCP dựa trên các thông số kỹ thuật CoS. Thêm vào đó R3 gọi những quý giá DSCP. cho các gói tin đã đi ra cổng F0/0 về SW2, gán giá trị trong 802.1Q header. Giá trị đích thực bên trên cổng F0/0 của R3 mang đến quy trình phân các loại và khắc ghi nlỗi sau: Các frame lấn sân vào với mức giá trị CoS 5 sẽ được gán cực hiếm DSCPhường EF (nút ưu tiên phệ nhất) Các frame đi vào với mức giá trị CoS 1 sẽ tiến hành gán quý giá AF11.

3, Mô hình Qos


Phân các loại (classification): Phân các loại một gói tin bằng phương pháp links nó cùng với nhãn QoS. Bộ biến đổi ánh xạ CoS hoặc DSCP.. trong gói cho tới nhãn QoS nhằm phân biệt một một số loại lưu lại lượng truy vấn với 1 nhiều loại không giống. Kiểm tra gói với xác định nhãn qos dựa trên ACL hoặc cấu hình.

Chính sách và ghi lại (policing & marking):

Sau Khi gói được phân nhiều loại cùng tất cả nhãn QoS dựa trên DSCPhường hoặc dựa vào CoS được gán đến nó.

Policing tương quan tới sự việc tạo ra một policer xác định số lượng giới hạn đường truyền mang đến lưu lại lượng truy vấn. Các gói thừa vượt giới hạn nằm kế bên cấu hình hoặc không tương xứng. Mỗi policer quyết định bên trên đại lý packet-by-packet mặc dầu gói tin cân xứng hay là không cân xứng cùng chỉ định những hành động trên gói. Những hành vi này, được triển khai vày marker, bao gồm trải qua gói tin nhưng mà không sửa thay đổi, quăng quật gói tin, hoặc sửa đổi (ghi lại xuống) DSCPhường được hướng đẫn của gói cùng cho phép gói trải qua.

Hàng ngóng (queue):

Hàng hóng Đánh Giá nhãn QoS với cực hiếm DSCP. hoặc CoS khớp ứng nhằm chọn thành nhị sản phẩm hóng nhtràn lên để đặt gói tin. Xếp sản phẩm được bức tốc cùng với thuật toán weighted tail drop (WTD), một phương pháp rời tắc nghẽn. Nếu vượt thừa ngưỡng, gói tin đang bị loại quăng quật.

Lập planer hình thức dịch vụ những sản phẩm đợi dựa vào shaped round robin (SRR) được định cấu hình của bọn chúng. Một trong những sản phẩm hóng đột nhập là sản phẩm đợi ưu tiên, với SRR các dịch vụ nó mang đến share được cấu hình của nó trước khi phục vụ hàng đợi khác

4. Cấu hình Standard Qos bên trên Switch layer 3

Khởi tạo thành Qos trên switch 3750 catalyst (mang định disable)

Sw(config) mls qos no mls qos

Show mls qos

Khởi sinh sản qos dựa vào vlan

Int g0/0

Sw(config) mls qos vlan-based no mls qos vlan-based

Show mls qos int g0/0

Cấu hình qos bên trên những cổng tin tưởng (mặc địch không tin cậy)

Sw(config) int g0/0

Mls qos trust no mls qos trust int g0/0

Cấu hình giá trị cos, dscp, ip pre mang đến gói tin thông số kỹ thuật class-map:

Câu lệnh class-map: dùng để làm phân một số loại lưu lượng dữ liệu theo ý muốn của người tiêu dùng, rất có thể thực hiện kết phù hợp với các hình thức phân các loại như ACL giỏi cần sử dụng vẻ ngoài NBAR.Câu lệnh policy-map: dùng để khí cụ giải pháp hành xử mang đến từng các loại lưu lượng đã làm được phân các loại, cách hành xử có thể đơn giản là phân các loại tài liệu, hoàn toàn có thể là lưu lại thường được sử dụng trong những nguyên tắc QoS không giống, chăm chú là luôn tồn ở một loại thông số kỹ thuật class-maps tên là class-default nhằm mục đích phân nhiều loại tất cả các lưu giữ lượng chưa được phân nhiều loại vì đều class-maps trước.

SW (config) # class-mapname

SW (config-cmap) # match access-group Name access-list-name

SW (config-cmap) # match coscos-value

SW (config-cmap) # match dscpdscp-value-1

SW (config-cmap) # match ip precedenceip-precedence-value-1

Hoặc

SW (config)#policy-mapname

SW (config-pmap)#classname

SW (config-pmap-c)#set ip precedenceip-precedence-value-1

SW (config-pmap-c)#set dscpdscp-value-1

SW (config-pmap-c)#phối cos cos-value

Ta có:

SW (config-cmap) # class-map (match-any | match-all)name

SW (config-cmap) # match access-group name test

SW (config-cmap) # match int f0/1


Ví dụ: Cấu hình trên SWC làm thế nào để cho PC0, PC1 lượng traffic mail được ưu tiên rộng cùng với website, với traffic còn lại của VPS local

Bước 1: Tạo 2 access danh sách mail (pop3) vs web (http https)

SWC(config)#ip access-danh sách extendedmail

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 110

SWC(config-ext-nacl)#ex

SWC(config)#ip access-các mục extendedweb

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 80

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 443

Bước 2: Tạo 2 class map tương xứng với access-list

SWC(config)#class-mapmail

SWC(config-cmap)#match access-group namemail

SWC(config-cmap)#ex

SWC(config)#class-mapweb

SWCconfig-cmap)#match access-group nameweb

SWC(config-cmap)#ex

Bước 3: Tạo policy maps cùng gán giá trị ip precedence, class-default là lượng traffic còn lại.

SWC(config)#policy-mapabc

SWC(config-pmap)#classmail

SWC(config-pmap-c)#set ip precedence 3

SWC(config-pmap-c)#ex

SWC(config-pmap)#classweb

SWC(config-pmap-c)#set ip precedence 2

SWC(config-pmap-c)#ex

SWC(config-pmap)#class class-default

SWC(config-pmap-c)#phối ip precedence 1

SWC(config-pmap-c)#end

Cách 4: Gán policy-map vào cổng

SWC(config)#int range f0/1-2

SWC(config)# service-policy inputabc

Vậy tại chỗ này bọn họ đang ưu tiên các gói tin theo mail với mức giá trị ip predence cao hơn bắt buộc đi trước, cho nên vì thế sẽ truy cập nkhô cứng rộng so với website cùng luồng tin sót lại.

Gán giá trị cos-to-dscp: Bạn áp dụng CoS-to-DSCPhường. để ánh xạ các giá trị CoS trong các gói tài liệu đến một quý hiếm DSCP mà QoS áp dụng trong nội bộ nhằm bộc lộ mức độ ưu tiên của lưu giữ lượng truy vấn.

Xem thêm: Mua Bán Nhà Đất Trung Văn, Quận Nam Từ Liêm, Bán Đất Xã Trung Văn, Quận Nam Từ Liêm

SW1(config)#mls qos maps ?

cos-dscp cos-dscp map: eight dscp values for cos 0-7

SW1(config)#mls qos map cos-dscp 0 8 16 24 32 46 48 56

SW1(config)#exit

SW1#show mls qos maps cos-dscp

Cos-dscp map: cos: 0 1 2 3 4 5 6 7

dscp: 0 8 16 24 32 46 48 56

Vậy tất cả cực hiếm cos trường đoản cú 0 cho 7 được gán quý hiếm DSCPhường. theo đồ vật tự: 0, 8, 16, 24, 32, 46, 48, 56

Ánh xạ cực hiếm dcsp-to-dscp mutation map: Nếu nhị miền QoS có DSCPhường khác biệt, hãy áp dụng DSCP-to-DSCP mutation bản đồ để dịch một cỗ quý giá DSCPhường. nhằm tương xứng cùng với khái niệm của miền không giống.

Giá trị DSCP new đã ghi đè lên trên một gói vào gói với QoS cách xử trí gói với giá trị mới này. Công tắc đã gửi gói tin thoát ra khỏi cổng với cái giá trị DSCPhường bắt đầu.

quý khách rất có thể cấu hình những DSCP-to-DSCPhường mutation map trên cổng vào.


SW1(config)#mls qos bản đồ dscp-mutationDEMO24 26 28 30 khổng lồ 24

SW1(config)#interface gig 1/0/8

SW1(config-if)#mls qos trust dscp

SW1(config-if)#mls qos dscp-mutation

DEMO SW1(config-if)#vì chưng show mls qos maps dscp-mutation

Dscp-dscp mutation map:


Các quý hiếm dscp 24 26 28 30 đang ánh xạ thành 24

5. Cấu hình qos bởi policy maps và class map

Cấu hình với cùng một luồng đường đi

Cách 1: Tạo class-bản đồ kết phù hợp với access-các mục, bạn cũng có thể cần sử dụng access-danh mục theo từng host PC, hoặc theo từng dịch vụ nhỏng web, mail.

Switch(config)# access-danh mục 1 permit 10.1.0.0 0.0.0.255

Bước 2: Tạo policy-map kết hợp với class-map ở trên, tiếp nối thông số kỹ thuật để tăng bớt đường dẫn, 1000000: Băng thông giới hạn bps, 8000: Tốc độ burst Bytes

Switch(config)# class-mapipclass1

Switch(config-cmap)# match access-group 1

Switch(config-cmap)# exit

Switch(config)# policy-mapflow1t

Switch(config-pmap)# classipclass1

Switch(config-pmap-c)# trust dscp

Switch(config-pmap-c)# police 1000000 8000 exceed-action policed-dscp-transmit

Switch(config-pmap-c)# exit

Switch(config-pmap)# exit

+ Cách 3: Cấu hình gán dịch vụ policy vào cổng đồ gia dụng lí, input đầu vào hoặc output

Switch(config)# interface gigabitetheg0/0

Switch(config-if)# service-policy inputflow1t

Ở phía trên họ gồm hình cấu hình qos trên SW 3560 nhằm tăng giảm băng thông đến vùng mạng Lan, mặc dù tùy thuộc vào lượng băng thông mà ISPhường. cung cấp mang đến. Dường như có thể thông số kỹ thuật qos trên Router ISP.

Cấu hình với tương đối nhiều luồng mặt đường đi:


Sử dụng chính sách aggregate

Cách 1: Tạo aggregate-police cùng với 320000 là băng thông, 8000 là tốc độ burst.

SW1(config)#mls qos aggregate-policeWeb-telnet320000 8000 exceed-action drop

Cách 2: Tạo 2 access-các mục, tạo 2 class-maps gán với 2 access-danh sách đó

SW1(config)#access-list 100 permit tcp 192.168.1.0 0.0.0.255 192.168.trăng tròn.6 0.0.0.0 eq 80

SW1(config)#access-menu 2 permit 192.168.2.0 0.0.0.255

SW1(config)#class-mapweb

SW1(config-cmap)#match access-group name 100

SW1(config-cmap)#exit

SW1(config)#class-maptelnet

SW1(config-cmap)#match access-group name 2

SW1(config-cmap)#exit

+ Cách 3: Tạo policy-map AGGREGATE

SW1(config)#policy-map AGGREGATE

SW1(config-pmap)#class web

SW1(config-pmap-c)#police aggregateWeb-telnet

SW1(config-pmap-c)#exit

SW1(config-pmap)#class telnet

SW1(config-pmap-c)#police aggregateWeb-telnet

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

Bước 4: Gán service policy vào cổng đồ dùng lí

SW1(config)#interface f0/1-2

SW1(config-if)#service-policy đầu vào AGGREGATE

Vậy thì PC0 sẽ truy vấn web và PC1 temang lại server local, với lượng đường dẫn thông thường đã thông số kỹ thuật là 3,2Mbps

Policing a Switched Virtual Interface:

Bước 1: Cấu hình tin yêu vlan-based trên cổng đồ dùng lí.

SW1(config-if-range)#mls qos vlan-based

SW1(config-if-range)#exit

Bước 2: Tạo access-các mục, tạo 1 class-bản đồ tương ứng, chế tạo ra 1 class-bản đồ gán với cổng đồ vật lí.

SW1(config)#access-list 100 permit udp any any range 16384 32767

SW1(config)#class-maps RTP

SW1(config-cmap)#match access-group 100

SW1(config-cmap)#exit

SW1(config)#class-maps PORTS

SW1(config-cmap)#exit

Bước 3: Tạo 1 policy-map để số lượng giới hạn đường truyền (child policy map), tạo ra 1 policy maps (parent policy map) để gán quý hiếm dscp, gán them child policy-map nghỉ ngơi trên

SW1(config)#policy-maps PORT

SW1(config-pmap)#class PORTS

SW1(config-pmap-c)#police 256000 8000 exceed-action drop

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

SW1(config)#policy-maps VLAN

SW1(config-pmap)#class RTP

SW1(config-pmap-c)#mix dscp 46

SW1(config-pmap-c)#service-policy PORT

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

SW1(config)#int vlan 100

SW1(config-if)#service-policy đầu vào VLAN

Dưới dây là 1 trong những ví dụ khác: Đây là hầu như vlan sẽ có với thưởng thức là cung cấp đường truyền, đặt giá trị ip precedence cho từng loại hình dịch vụ. Ta đã thông số kỹ thuật bên trên sw 3560

VLAN ID VLAN NAME BANDWIDTH PRECEDENCE

--------------------------------------------------------------------------------

10 IPMux 16 Mbps 5

20 Cameras 2 Mbps 7

30 Scadomain authority 6 Mbps 6


Cách 1: Khởi chế tạo ra qos

mls qos

Bước 2: Tạo policy map:

Ví dụ: policy-map bw6M (child policy map) để số lượng giới hạn băng thông, policy-maps vlan 30 (parent policy-map) để đặt giá trị ip precedence

!

policy-map bw6M

mô tả tìm kiếm *************** VLAN 30 Scada ***************

class class-default

police 6000000 8000 exceed-action drop

policy-map VLAN30

class class-default

set precedence 6

service-policy bw6M

!

policy-maps bw2M

description *************** VLAN đôi mươi Cameras ***************

class class-default

police 2000000 8000 exceed-action drop

policy-bản đồ VLAN20

class class-default

phối precedence 7

service-policy bw2M

!

policy-map bw16M

description *************** VLAN 10 IPMux ***************

class class-default

police 16000000 8000 exceed-action drop

policy-map VLAN10

class class-default

set precedence 5

service-policy bw16M

Bước 3: Cấu hình bên trên cổng: access vlan cùng qos cho vlan

interface FastEthernet0/1

switchport mode access

mls qos vlan-based

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/3

switchport access vlan 30

switchport mode access

mls qos vlan-based

!

!

Bước 4: Cấu hình trunking

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos vlan-based

Bước 5: Assign the policy maps khổng lồ the SVIs: Gán policy-bản đồ vào vlan

!

interface Vlan10

no ip address

service-policy input VLAN10

!

interface Vlan20

no ip address

service-policy input đầu vào VLAN20

!

interface Vlan30

no ip address

service-policy input đầu vào VLAN30

!

Congestion Management:Quản lí tắc nghẽn

quý khách có thể ưu tiên lưu giữ lượng bằng cách đặt các gói gồm DSCP. hoặc CoS vào những sản phẩm đợi một mực và kiểm soát và điều chỉnh ngưỡng mặt hàng đợi nhằm những gói bao gồm cường độ ưu tiên thấp hơn bị nockout bỏ

Ánh xạ quý giá cos hoặc dscp cho tới hàng chờ (queue) và ngưỡng (threshold)

Theo khoác định, những giá trị DSCP 0–39, 48–63 được ánh xạ tới queue 1 với threshold 1. Các giá trị DSCP. 40–47 được ánh xạ cho tới queue 2 cùng threshold 1.

Theo mặc định, quý hiếm CoS 0–4, 6 cùng 7 được ánh xạ tới queue 1 cùng threshold 1. Giá trị CoS 5 được ánh xạ tới queue 2 và threshold 1.

Queue: từ là 1 mang đến 2.Threshold: 1 cho 3..

Gán nhì phần trăm ngưỡng WTD đến (threshold 1 cùng 2) vào sản phẩm chờ nhập. Mặc định, cả nhì ngưỡng được đặt thành 100%.

Đối cùng với ngưỡng Phần Trăm tỷ lệ ngưỡng1, phạm vi từ là một đến 100. Tách từng giá trị bởi khoảng tầm White.

Mỗi quý giá ngưỡng là Phần Trăm của tổng thể bộ biểu đạt hàng hóng được phân chia mang lại sản phẩm đợi.

VD:

Switch(config)# mls qos srr-queue input dscp-maps queue 1 threshold 1 0 1 2 3 4 5 6

Switch(config)# mls qos srr-queue đầu vào dscp-maps queue 1 threshold 2 đôi mươi 21 22 23 24 25 26

Switch(config)# mls qos srr-queue đầu vào threshold 1 50 70

ví dụ như này cho biết thêm bí quyết ánh xạ quý hiếm DSCPhường 0 cho 6 để nhập khẩu chờ 1 (queue) và đến ngưỡng 1 (threshold) với ngưỡng bớt 1/2. Nó ánh xạ các giá trị DSCP. từ 20 cho 26 để nhập hàng hóng 1 cùng mang đến ngưỡng 2 cùng với ngưỡng giảm 70%. Trong ví dụ này, những cực hiếm DSCPhường (0 đến 6) được gán ngưỡng WTD là một nửa với sẽ bị loại quăng quật mau chóng rộng cực hiếm DSCP (trăng tròn mang lại 26) được gán mang đến ngưỡng WTD là 70%.

Bên cạnh đó rất có thể ánh xạ giá trị cos

Switch(config)# mls qos srr-queue đầu vào cos-bản đồ queuequeue-idthresholdthreshold-id cos1...cos8

Shaped Round Robin (SRR):

SRR tất cả 2 chính sách hoạt động

Shaped

Chỉ có sẵn bên trên hàng hóng đi ra.

Hàng hóng nhận được một trong những phần dự trữ một trong những phần của một cổng đường truyền cùng không hề nữa.

Shared

Có sẵn trên hàng hóng vào với ra.

Hàng ngóng được bảo đảm an toàn một phần của cổng đường dẫn.

Bandwidth Allocation for Input Queues (shared mod):Gắn băng thông vào hàng đợi đầu vào (queue)

SW1(config)#mls qos srr-queue input đầu vào bandwidth 30 70

30% đường dẫn đến queue 1 cùng 70% mang đến queue 2

Bandwidth Allocation for Output đầu ra Queues (shared mod):Gán đường truyền mang đến sản phẩm chờ áp ra output.

SW1(config)#int gig 1/0/4

SW1(config-if)#tốc độ 1000

SW1(config-if)#srr-queue bandwidth nói qua 10 25 35 50

BW for Q1: * 1000 Mbps = 83.3 Mbps

BW for Q2: * 1000 Mbps = 208.3 Mbps

BW for Q3: * 1000 Mbps = 291.7 Mbps

BW for Q4: * 1000 Mbps = 416.7 Mbps

Bandwidth Allocation for Output đầu ra Queues (Shaped Mode): Băng thông giới hạn

SW1(config)#int gig 1/0/5

SW1(config-if)#speed 1000

SW1(config-if)#srr-queue bandwidth shape 30 0 0 0

Determine the amount of bandwidth limits applied to the output queues on interface Gigabit Ethe1/0/5.

BW Limit for Q1: 1/30 * 1000 Mbps = 33.3 Mbps

BW Limit for Q2: No limit applied

BW Limit for Q3: No limit applied

BW Limit for Q4: No limit applied

Example:

SW1(config)#int gig 1/0/6

SW1(config-if)#tốc độ 1000

SW1(config-if)#srr-queue bandwidth cốt truyện 100 100 40 20

SW1(config-if)#srr-queue bandwidth shape 50 50 0 0

BW Limit for Q.1 (Mbps): (1/50) * 1000 = 20 Mbps

BW Limit for Q.2 (Mbps): (1/50) * 1000 = trăng tròn Mbps

Total Bandwidth (Mbps) = trăng tròn + 20 + 640 + 320 = 1000 Mbps

Limiting Bandwidth on an Output đầu ra Interface:

SW1(config-if)#srr-queue bandwidth limit 85

The interface’s outbound bandwidth is limited khổng lồ 85 percent of the interface speed


Chuyên mục: Đầu tư